CORRECT TEXT
Scenario:
You work for SWITCH.com. They have just added a new switch (SwitchB) to the existing network
as shown in the topology diagram.
RouterA is currently configured correctly and is providing the routing function for devices on
SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to
support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with
competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the
enable password.
Configuration Requirements for SwitchA
The VTP and STP configuration modes on SwitchA should not be modified.
• SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should
be left are their default values.
Configuration Requirements for SwitchB
• Vlan 21
Name: Marketing
will support two servers attached to fa0/9 and fa0/10
• Vlan 22
Name: Sales
– will support two servers attached to fa0/13 and fa0/14
• Vlan 23
o Name: Engineering
o will support two servers attached to fa0/15 and fa0/16
• Access ports that connect to server should transition immediately to forwarding state upon
detecting the connection of a device.
• SwitchB VTP mode needs to be the same as SwitchA.
• SwitchB must operate in the same spanning tree mode as SwitchA
• No routing is to be configured on SwitchB
• Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24
Inter-switch Connectivity Configuration Requirements
• For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and
23 should tagged when traversing the trunk link.
• The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for
the maximum use of their bandwidth for all vlans. This mode should be done with a nonproprietary protocol, with SwitchA controlling activation.
• Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk
link.
Answer: See the explanation
Explanation:
Here are steps:
hostname SWITCH_B
!!
vlan 21
name Marketing
vlan 22
name Sales
vlan 23
name Engineering
!!
interface FastEthernet0/3
switchport trunk allowed vlan 1,21-23
channel-protocol lacp
channel-group 1 mode passive
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 1,21-23
channel-protocol lacp
channel-group 1 mode passive
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 21
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 21
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 22
switchport mode access
spanning-tree portfast
!!
interface FastEthernet0/14switchport access vlan 22
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 23
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 23
switchport mode access
spanning-tree portfast
!!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
spanning-tree allowed vlans 1,21-23
!
interface Vlan1
ip address 192.168.1.11 255.255.255.0
!
end
SWITCH_B(config)#
hostname SWITCH_A
!
panning-tree vlan 11 root primary
spanning-tree vlan 12 root primary
spanning-tree vlan 13 root primary
spanning-tree vlan 21 root primary
spanning-tree vlan 22 root primary
spanning-tree vlan 23 root primary
!
interface FastEthernet0/3
switchport trunk allowed vlan 1,21-23
channel-protocol lacpchannel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 1,21-23
channel-protocol lacp
channel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/21
switchport access vlan 21
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 22
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 23
switchport mode access
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Port-channel 1
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 192.168.1.1
!!
End
kann alles gelöscht werden, ist total verkehrt !!!
>> So sollte es besser gehen <<
SwitchA#
vlan 21
name Marketing
exit
vlan 22
name Sales
exit
vlan 23
name Engineering
exit
int range f0/3-4
no switchport mode access
no switchport access vlan 98
channel-protocol lacp
channesl-group 1 mode active
no shut
exit
int port-channel 1
switchport mode trunk
switchport trunk native vlan 99
switchport trunk allowed vlan 1,21-23
no shut
exit
SwitchB#
conf t
vlan 21
name Marketing
exit
vlan 22
name Sales
exit
vlan 23
name engineering
exit
vlan 99
name TrunkNativ
exit
int range f0/9-10
switchport mode access
switchport access vlan 21
spanning-tree portfast
no shut
exit
int range f0/13-14
switchport mode access
switchport access vlan 22
spanning-tree portfast
no shut
exit
int range f0/15-16
switchport mode access
switchport access vlan 23
no shut
exit
vtp mode transparent
spanning-tree mode rapid-pvst
ip default-gateway 192.168.1.1
int vlan 1
ip add 192.168.1.11 255.255.255.0
no shut
exit
int range f0/3-4
channel-protocol lacp
channel-group 1 mode passive
no shut
exit
int port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 99
switchport trunk allowed 1,21-23
no shut
exit
You’re right, you need to add VLAN’s 21-23 on both switches but yo forgot to make Switch A the root for VLAN 11-13, 21-23 which you need to enter the following after the other config to make sure the changes don’t get overridden.
spanning-tree vlan 11 root primary
spanning-tree vlan 12 root primary
spanning-tree vlan 13 root primary
spanning-tree vlan 21 root primary
spanning-tree vlan 22 root primary
spanning-tree vlan 23 root primary
One more thing, why native VLAN 99? is that just a random one so it tags VLAN 1? I understand a non-used VLAN for the native is the Cisco way though in real world you can also just force native tagging.
Great !!!!
can anyone tell me please did they change 300-115 (v.1). I am planning to take exam at December 10.