You have configured a DMVPN hub and spoke as follows (assume the IPsec profile “dmvpnprofile” is configured correctly):
Hub:
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp holdtime 600
ip nhrp redirect
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 10000
tunnel protection ipsec profile dmvpnprofile
Spoke 1:
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast 1.1.1.2
ip nhrp map 172.16.1.1 1.1.1.2
ip nhrp network-id 20
ip nhrp holdtime 300
ip nhrp nhs 172.16.1.1
ip nhrp shortcut
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1000
tunnel protection ipsec profile dmvpnprofile
With this configuration, you notice that the IKE and IPsec SAs come up between the spoke and the hub, but NHRP registration fails. Registration will continue to fail until you do which of these?
A.
modify the NHRP hold times to match on the hub and spoke
B.
modify the NHRP network IDs to match on the hub and spoke
C.
modify the tunnel keys to match on the hub and spoke
D.
configure the ip nhrp cache non-authoritative command on the hub’s tunnel interface