What is wrong with the following BGP configuration? !
interface loopback0
ip address 1.1.1.1 255.255.255.255
!
interface s0
ip address 172.16.1.2 255.255.255.0
!
interface e1
ip address 10.1.1.1 255.255.255.0
!
interface e2
ip address 10.1.2.1 255.255.255.0
!
router bgp 65101
neighbor 172.16.1.1 remote-as 65102
neighbor 3.3.3.3 remote-as 65101
neighbor 3.3.3.3 update-source loopback0
network 10.1.0.0 mask 0.0.255.255
no auto-summary
!
router eigrp 100
network 10.0.0.0
network 1.0.0.0
A.
The network 10.1.0.0 mask 0.0.255.255 statement is wrong.
B.
The auto-summary configuration statement is missing under router bgp 65101.
C.
The neighbor 3.3.3.3 ebgp-multihop 2 configuration statement is missing under router bgp 65101.
D.
The neighbor 172.16.1.1 ebgp-multihop 2 configuration statement is missing under router bgp 65101.
E.
The neighbor 3.3.3.3 remote-as 65101 and the neighbor 3.3.3.3 update-source loopback0 configuration statements should be changed to neighbor 1.1.1.1 remote-as 65101 and neighbor 1.1.1.1 update-source loopback0.
F.
The loopback0 interface IP address should be 3.3.3.3 255.255.255.255.
Explanation:
BGP doesn’t use reverse mask like access lists. The correct command would be network 10.1.0.0 mask 255.255.0.0